Back to overview
Downtime

Incident #10.23.2025

Oct 23 at 03:07am MDT
Affected services
Validator Health

Resolved
Oct 23 at 03:38am MDT

Services were restored

Created
Oct 23 at 03:07am MDT

At 09:07 UTC, our validator encountered a system-level failure that briefly interrupted operations. Services were fully restored within 32 minutes, with no leader slots missed during that period. Following a detailed post-incident review, our team is implementing several technical and operational improvements to reduce the likelihood of recurrence and to further shorten recovery times.